Jump to content


  • Content count

  • Joined

  • Last visited

Community Reputation

0 Neutral

About Cleans13yo

  • Rank

General Info

  • Location
    Australia QLD
  • Car Type
    Nissan Silvia
  • Car Model
  1. Advice on h22 mods

    Hey, Looking at getting these for my h22 VTEC motor. Skunk2 Pro Intake Manifold Skunk2 Alpha 70mm Throttle Body Skunk2 TunerStage 2 Cams Skunk2 Pro Cam Gears Skunk2 Tuner Springs/Titanium Retainers Do else need anything else? Obviously a tune and what sort of power would it produce? Thanks!
  2. S13 'reppin.

  3. SR20 help please

    okay, checked fuel pressure is fine, changed AFM, mass flow to was fine. Timing is back to stock, doing spark plugs as they were pretty bad and will find out tomorrow after work.
  4. Hey NS. Just picked up a S13 /with an S15 Autech motor in it, basically the fuel tank ran dry conked out 3 times before getting to the servo, fillled up and was all good. The next day under slight throttle the car felt like it was getting enough fuel.... anyway tonight myself and a mate have spent some time going over somethings and basically after some help! I changed the Fuel filter, basically because figured bottom of the tank grose fuel w/e, we looked at the timing, maybe it was out and wasn't getting enough fuel and it had a marking on it where it had been advanced before, so we put it there and no difference. We're thinking maybe the fuel pump? Spark leads/coilpack? It's not a miss fire though, its like it's fuel starved and under heavier 40%+ throtttle control it runs fine. Any help would be awesome, thanks!
  5. RONE SHIRYO's Shinigami Silvia [updated 17/07]

    Wowie. Totally read this for nearly an hour and i take my hat off to you like everyone else has, and the work that Primal garage has done for you. Don't sell it mate, I have a project S13 ( P plate ) coming up and i can't wait but it never happens over night, money doesn't grow on a tree and like someone else said if you go all out at the start and how you have stated you loose motivation. Good things happen over time, and on day you'll see haha. Keep it going mate
  6. KE70 Engine swap, All opinions welcome.

    Oh alright, I haven't got it yet but looking at it tomorrow. Has anyone ever done a RB20 into a KE? Is the engine bay to small? have to custom cut into the firewall? Not that i want to, but it is different haha. Well, not a fan of the CA, it's either a SR20DE or a 4AGE, i really only like the 20v bigports but a 16v would be fine. Custom engine mounts and little things don't seem to much of a hassle either.
  7. KE70 Engine swap, All opinions welcome.

    Yeah i got quoted for a 4age with xxxxxxx k's with just the intake for 900. The 4k/5k has some work done so I'm taking it for a drive this weekend. I read on ae86drivingclub.com.au someone sells SR20DE kits for KE70s, so maybe that could be an avenue? But with upgrading or engine swapping, i'd have to upgrade the brakes etc to. I just want a little more power thats all, and if i can get the SR20DE dropped in, wired up and everything running for a decent price i think it'd be worth it. I know nothing about these carbie motors :\
  8. So basically, I could be getting a KE70 in the upcoming week and are not that excited about the 5k with the 4k bottom end in it. It has had some work done to it but i hae 2 options i'm considering and no nothing about the setups of Toyota's so this will be a first. I want to engine swap either a; 4AGE 16v or 20v SR20DE Now i can get both and being a Nissan guy i lean towards the SR but the 4age doesn't have any bad points. I have researched both this on google, and have found soe topics but nothing with really prices in them and they're fairly old. I just want information like, will the SR20DE drop in? Vice-versa, What other items do i need that the KE driveline can't adjust to etc. Any information would be awesome, thank you.
  9. My S14 skid car...

    That looks mad as! Really a fan, not a big fan of S14's but yours is nice. Lucky gf
  10. S13 'reppin.

    I was going to modifiy the stock SR to get some more power out of it, but after reseach i might Autech it and for that reason i haven't changed them back.
  11. S13 'reppin.

    Engine: SR20DE 120,000 kms Exhaust: 2.25 catback exhaust with a xforce twin tip muffler Suspension: BC Coilovers Wheels: XXR 002 16x8 -0 Black with polished lip /w some 205/50/16 Kumho KU31 Tyres. Modifications: Tomei camshafts, 500cc injectors, Pod, Pacemaker extractors, Shimmed RS200 diff, Nismo rear strutbrace, Adj castor rods/camber arms, S15 seats, Spitfire leads, Iridium plugs, Tinited/smoked parkers/lights allround, x2 10inch thermo fans /w switch in cabin, Slottered rotors, Short shift kit and some other things. Stereo Audio: Alpine headunit with JVC splits and tweeters, x2 6x9 type r alpine speakers, option Audio 800wrms monoblock and pioneer sub ( which just blew up lol ) Future plans; Aero side skirts ( have, need touching up + painted ) Nardi steering wheel S15 rear seats ( have, not fitted ) Work Meisters S1 2p ( still undecided ) Roof spoiler Walbro fuel pump Lower it = 110mm Finally pulled the camera out of the glove box and thought i'd show NS my S13. When i bought it, it was a Midnight purple code 1 ( Off a R33 GTR ) but it was fading bad and started to peel and decided to get a re-spray in Midnight purple ( lamborghini ) couldn't afford the 4k re-spray. I fixed up the Aero bar that came with it and put it on, Also found some Genuine Silvia floor mats <3 and a new set of Coilovers, injectors and camshafts. Hope you like it; Currently sits @ 125mm and i have had it @ 95mm just for the looks but because of cop attention so much these days it sits @ 125mm but i'll lower it maybe this weekend not sure.
  12. SR20DE noise.

    Hadn't started my S13 up for about a month, Today i started it up and was fine then about 10 seconds in i felt this movement in the seat ( One of my Engine mounts is currently busted, half sitting there basically ) i opened the bonnet and my engine was like wobbleing every 2-3 seconds. It wasn't a knock or anything as i'm pretty sure i could tell, didn't sound anything top or bottom end. I'm thinking something to do with fuel? It's like the fuel is cutting out or a lack of flow? I had just recently serviced it and the guy i bought it off ran sludge through it ( was so thick the oil ) but i didn't think this is the cause, just more information. any help appreciated, could upload a video on my iPhone tomorrow.
  13. That's insane, Awesome thread man. I would just wait for my opens to build something, their is only so much you can get on a NA motor, But thats my opinion. Will keep a look @ this thread, gl.
  14. Always Mongo s13

    i can get you one if you'd like also can get a hold of most automotive parts through my business ; BITSUS Customs PM me mate about prices etc.