Jump to content
Sign in to follow this  
sc s15

S13 Silvia Race Car. 2015 season finished.

Recommended Posts

Thanks. Yeah compression plus a bitmon the dirty part of the track.

Share this post


Link to post
Share on other sites

Just watched the vids, what a wild ride, 150km+ on that first off 0_0 No tyre damage? So good to keep it off the tyres/wall.

 

Fast track and some decent steering mate, I'm lucky to peak 175 down the back straight at Winton, and that's just in a straight line, not steering through a bend like you.

 

Awesome stuff.

Share this post


Link to post
Share on other sites

I'm having a bit of an eventful weekend. Fuel line came off the rail again somehow, it was tight but either wrong clamp or wrong hose let it come off again. It would've been fine but I tried to restart it and had a bit of a fire...

 

Luckily the marshall had it out within a couple of seconds and it only did minor wiring damage.

 

Replaced the fuel hose and put 2 different clamps on it. Taped up the burnt wires. Should be good to go for the rest of the weekend.

 

10566065_802751843090675_606209238_o.jpg

 

http://www.youtube.com/watch?v=y7eyYmkPScs&feature=youtu.be

  • Upvote 2

Share this post


Link to post
Share on other sites

Great photo of a bad situation man.

 

Glad to hear that you and the car are ok.

Share this post


Link to post
Share on other sites

Amazing photo! Buy the print!

 

So glad you weren't hurt mate, that must have been some *Laundo* puckering stuff right there. So lucky/smart that you pulled over near the marshals.

Share this post


Link to post
Share on other sites

Well that would have been abit of an adrenaline rush mate, glad to see you got out real quick and the cars ok

Looks like the Lakeside Marshall's could teach the Hungarians how to put out a fire after Lewis Hamiltons efforts last night

Share this post


Link to post
Share on other sites

Shit!

 

Good to hear the damage isnt that bad.

 

Interesting though, where was your extinguisher located?

Share this post


Link to post
Share on other sites

Car ran ok today. No issues from the fire. Ended up midfield all weekend, just didnt have enough confidence to keep up with some of the faster cars. Quallified within a couple of tenths of my pb, spent most of the races in close battles with a couple of cars which is always fun.

 

 

Extinguisher is on the tunnel next to my seat. First priority was to get out of the car obviously and evaluate from there. With the size of the fire initially I just wanted to get out ASAP.

Share this post


Link to post
Share on other sites

Car ran ok today. No issues from the fire.

 

 

That's good to hear mate .

 

Extinguisher is on the tunnel next to my seat. First priority was to get out of the car obviously and evaluate from there. With the size of the fire initially I just wanted to get out ASAP.

 

I thought that was the case as it didn't seem as though you even tried to grab it. Interesting food for thought...

Share this post


Link to post
Share on other sites

I think I'd have done the same seeing those flames up the window.

 

Can always buy a new car.

Share this post


Link to post
Share on other sites

wow that IS a bit of a scare, good to know no major damage.

Share this post


Link to post
Share on other sites

Wow man - Very intense - Glad your ok.

Share this post


Link to post
Share on other sites

Jesus man glad there was no major damage, shall be checking and re checking all my new lines

Share this post


Link to post
Share on other sites

Had a race meeting at QR on the weekend, had a shocker in qualifying with a wet track and no suitable tyres. Ended up 21st I think. Track was mostly dry for race one, had an awesome first 5 or so laps battling with 4-5 cars and moving forward.

 

Then had a brake failure into turn 6, ended up hitting the tyres then the wall at around 60k's. Car isn't too bad, just bent the rad support and cosmetic damage. Turns out one of my rear brake nipples came loose, not sure why yet, haven't had motivation to look at it properly yet.

 

So much bad luck lately, really starting to get over spending so much time and money fixing the POS.

 

http://youtu.be/AvJWqiP93o4

10527513_1520768611487845_3205627726175368556_n.jpg

Share this post


Link to post
Share on other sites

Should of dropped it back a gear and drifted it onto the front straight :whistle:

Share this post


Link to post
Share on other sites

Dot points.

 

- I love that you're out very regularly racing this thing, it's what most of us wish we were doing every weekend.

- Bad luck on the brakes, thankfully it wasn't a high speed corner and the damage is minimal, most importantly you're all OK.

- Might be time to buy a lotto ticket mate... Fire... failed brakes... you sure you haven't pissed someone off?

- Those rear nipples seem quite sensitive to what torque is used on them, it's not a long thread. Almost feels like they should have some medium strength Loctite.

Share this post


Link to post
Share on other sites

man unlucky hey, did the pedal just go to floor or was it progessive

Share this post


Link to post
Share on other sites

you were doing awesome mate, sucks donkey balls about the brakes but at least your not hurt and the car isnt to badly damaged.

 

If your still feeling shit about the car just leave i in the garage for a couple of weeks then come back to it.

Share this post


Link to post
Share on other sites

Should of dropped it back a gear and drifted it onto the front straight whistle.gif

 

hahahaha my thoughts exactly.. Ken block does it!!!

 

But yeah unlucky about the brakes mate, as someone said above, in the grand scheme of things, it could have been WAAAY worse, and you weren't hurt, so it wasn't the worst crash in the world to have..

Share this post


Link to post
Share on other sites

Had brakes for the first half second or so of the stop, then the pedal went to the floor. I pumped the pedal half a dozen times before I went of track but it still had no pressure.

 

Yeah I think someone might've put a curse on me.

 

Both this and the fire turned out as well as they could've. Both incidents could've been a lot worse.

 

Will be rebuilding the calipers and putting new nipples on before next meeting. I'm pretty sure I tightened them normally last time they were bled so I'm not sure why they loosened. Will use some lock tight and torque wrench to make sure I've been doing them tight enough.

Share this post


Link to post
Share on other sites

Dissappointing =(

 

I look forward to your return

Share this post


Link to post
Share on other sites

Found out why I've been having low oil pressure at idle and why oil pressure has been taking 10s to build on startup.

Oil pickup has cracked all the way around. Oil pressure was fine with rpm over 1500 but only 8-10psi at idle. It strangley started the same weekend as the fire.

Got a new one from Taark today, installed it and oil pressure is back to normal.

 

Car is almost repaired from the accident. Calipers have been rebuilt, replaced the front guards and repaired the front bar.

10157361_10152693249837856_6738956027040810325_n.jpg

10553812_10204500044122882_313228462246603699_o.jpg

Share this post


Link to post
Share on other sites

Finally had a weekend of racing that didn't end in disaster. Ended up 3rd in B class in a 29 car field. Finished between 12th and 15th in all 4 races.

 

The car ran pretty much perfectly all weekend, it has a slight miss ATM but I think it just needs a new set of plugs.

 

Had some close battles in pretty much all the races. Pity I forgot to start the video for race 2, which was my best race of the weekend.

 

http://www.youtube.com/watch?v=F-VSvHAC5pg&list=UUChiUx1pwX1Kx4ir9QRLBFg

1656094_786387338073994_5932622153849630021_n.jpg

10734217_732258983519899_3364172618140407463_n.jpg

10420269_731781266901004_5170955431083369664_n.jpg

Share this post


Link to post
Share on other sites

Great stuff, looks like my splitter needs to be lower...

 

That Torana has some grunt.

Share this post


Link to post
Share on other sites

Yeah it does, would've been better if I hadn't gone from 3rd to 6th...

 

I run my splitter at about 75mm. Something around that should be fine.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×