Jump to content
Sign in to follow this  
pabs89

Had my chaser for a day and trouble already! engine light and ETCS

Recommended Posts

hey guys, got the chaser yesterday, ran awesome, until today i gave it some throttle coming out of a corner, in the rain tyres slipped a bit (traction control was on)

 

Now the car wont idle, and if i give it any throttle it will just choke and splutter at 2000 rpm...

 

checked the pod filter, no water, reset ecu and done verything i can think of....

 

 

PLEASE HELP!!!

Share this post


Link to post
Share on other sites

I don't know chasers but sounds like afm or piping leaks.

Share this post


Link to post
Share on other sites

Agree with the piping as an easier check, a clamp may have even worn through a joiner and its bleeding air through a split or something

Share this post


Link to post
Share on other sites

coke bottle lid used to block off bov hose had cracked and big hole through it.... sorted...

Share this post


Link to post
Share on other sites

chaser bov's only need the electric plug pulled to disable it no need to block it off with anything.

Share this post


Link to post
Share on other sites

oh really?? mine came without it so the pipes need to be plugged :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×