Jump to content
Sign in to follow this  
snakey180

s14 battery problems. help!

Recommended Posts

so my s14s battery was drained earlier so i bought a new one. but it was only rated 300 cca hoping its enough..

after connecting the battery i got no power at all not even my immobilizer.

 

the previous owner had all screws and shit in the terminals to hold the old battery in but my new batterys terminal was big enough to fit..

 

afaik the car should still receive some power at least right?

 

could my terminal plugs be damaged or could it be something else?

how easy is it to change the terminal connectors ?

any help would be great!

Share this post


Link to post
Share on other sites

If you're not getting any power it appears you may have blown the main fuse, changing battery terminals are easy, if you can fit a new battery to your car you can change your terminals.Terminals only break, they will work regardless, metal conducts electricity regardless form or shape or condition will still conduct electricity.

Share this post


Link to post
Share on other sites

If you're not getting any power it appears you may have blown the main fuse, changing battery terminals are easy, if you can fit a new battery to your car you can change your terminals.Terminals only break, they will work regardless, metal conducts electricity regardless form or shape or condition will still conduct electricity.

 

can you come have a look at it for me bro lol i know you know your electrical shit

i can pay for your petrol =P

ive been to your place before but ive forgot what for. pm me if you can

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×